Project

General

Profile

Bug #54

Ground Level Canal Flooding over trains when bridge is present

Added by Anonymous about 18 years ago. Updated about 18 years ago.

Status:
Resolved
Priority:
Normal
Category:
Minor
Target version:
-
Start date:
06/01/2006
Due date:
% Done:

0%

Estimated time:

Description

TTDPatch Version: 2.5 b5

When using canals to isolate a strip of land at ground level this is normally functional. However, building a brisge over this land causes the causeway to flood (This doesn't happen under earlier patch versions) Flooding occurs onto tiles containing trains - clicking these trains causes the game to crash. See attached savegame

History

#1

Updated by Anonymous about 18 years ago

Original Author: SuperTycoon
Title: Submitter: SuperTycoon

Submitted by SuperTycoon - sorry I left that blank

#2

Updated by Nathaniel Lake about 18 years ago

No Crashlog, makes it very hard to work out what is exactly wrong, as for the flooding, thats because of diagonal flloding, tiles can flood diagonally, you can disable this or build around it.

#3

Updated by Josef Drexler about 18 years ago

Title: works as intended

this is a side effect of diagonal flooding, either build more canals or turn off diagonal flooding

#4

Updated by Anonymous about 18 years ago

Title: by Jonty

When I load this savegame TTD crashes when the bridges flood and disappear...

#5

Updated by Anonymous about 18 years ago

Original Author: SuperTycoon
Title: Crashlog and Cfgs

Ok, i realise the problem with the construction now, but i think there could still be an issue with train tiles flooding. Cfgs and Crashlog uploaded (Sorry for the delay)

#6

Updated by Josef Drexler about 18 years ago

flooding under bridges happened even with vehicles present, fixed by Lakie in r467

Also available in: Atom PDF